TECHZEN Zenoss User Community ARCHIVE  

Snapshot error

Subject: Snapshot error
Author: Takuma Fukumoto
Posted: 2020-09-18 03:40

This is my first time installing zenoss.
I went through all the manual install instruction of Control Center(1.6.3) and  Core(6.3.2).
Both Browser interface worked and everything seemed well.
But when I try to take a snapshot I get this error.

# serviced service snapshot Zenoss.core
Unable to get storage status for dfs root

I've seen the same error when I installed percona.
I'm reviewing back the instructions but I have no idea.
Can someone tell me where I made a mistake.


Subject: RE: Snapshot error
Author: Michael Rogers
Posted: 2020-09-18 10:46


The DFS (distributed filesystem) is provided by the NFS service on your Control Center master.  When your error message comes up, it usually indicates that the NFS service is in a bad way.  

The Zenoss Knowledge Base has a good article on staged shutdown and startup:
This procedure should get NFS playing nicely again.  It's worth pointing out that the instructions were written for the enterprise product, Zenoss Resource Manager, and will differ a bit for you.  

1. Replace any reference to "Zenoss.resmgr" with "Zenoss.core"
2. If you're running a single-host installation, skip any references to worker nodes or Zookeeper ensemble.

Michael J. Rogers
Senior Instructor - Zenoss
Austin TX

Subject: RE: Snapshot error
Author: Takuma Fukumoto
Posted: 2020-09-25 02:01

Michael Thanks for the reply.

I tried the steps in the knowledge base and it didn't work.
But I found the error during the steps in the startup sequence.

W0923 02:09:36.357196 33635 status.go:207] Error getting driver status for path /opt/serviced/var/volumes: strconv.Pa
rseUint: parsing "1B-ブロック": invalid syntax
W0923 02:09:36.357278 33635 status.go:216] nil status returned for path /opt/serviced/var/volumes
time="2020-09-23T02:09:36Z" level=error msg="Unexpected error getting volume status" location="storagestatsreporter.g
o:80" logger=stats

I assumed that this error is caused by the language setting witch I choosed Japanese at the OS installattion.
And I reinstalled in the English OS it worked fine. Thanks for the advice.

Takuma Fukumoto

< Previous
Graph point name from SNMP output
Zenoss 4.2.5 - Modeler is not working