TECHZEN Zenoss User Community ARCHIVE  

Upgrading from core 5 to core 6.2

Subject: Upgrading from core 5 to core 6.2
Author: Jeremy Newell
Posted: 2018-07-06 15:52

I was able to upgrade my Zenoss Core 5 server to Core 6.2.   But I'm noticing a few odd things.  Around 5% of my devices seem to be reporting SNMP down errors.  But i can snmpwalk them fine. 

So I tried to remove one failing device.  Waited a bit and tried adding it back.  But the job failed with the following.

Any ideas what I'm missing?

2018-07-06 19:46:57,860 INFO zen.Job: Job 1aa12e1e-d33a-4fed-b01e-e4dc56d95c75 (Products.ZenModel.ZDeviceLoader.CreateDeviceJob) received
2018-07-06 19:46:57,956 INFO zen.Job: Starting job 1aa12e1e-d33a-4fed-b01e-e4dc56d95c75 (Products.ZenModel.ZDeviceLoader.CreateDeviceJob)
2018-07-06 19:47:00,181 ERROR zen.Job: Failed to create device.
Traceback (most recent call last):
File "/opt/zenoss/Products/ZenModel/", line 234, in _run
device = createDevice()
File "/opt/zenoss/Products/ZenModel/", line 230, in createDevice
performanceMonitor, manageIp, zProperties, deviceProps
File "/opt/zenoss/Products/ZenModel/", line 138, in load_device
zProperties=zProperties, **deviceProperties
File "/opt/zenoss/Products/ZenModel/", line 123, in manage_createDevice
File "/opt/zenoss/Products/ZenModel/", line 986, in setManageIp
if self._isDuplicateIp(ip):
File "/opt/zenoss/Products/ZenModel/", line 942, in _isDuplicateIp
dev = ipMatch.manageDevice()
AttributeError: manageDevice
2018-07-06 19:47:00,186 ERROR zen.Job: Job 1aa12e1e-d33a-4fed-b01e-e4dc56d95c75 failed with an exception
2018-07-06 19:47:00,187 ERROR zen.Job: <traceback object at 0x7f84dd0>
2018-07-06 19:47:00,296 INFO zen.Job: Dependent job(s) e326cb83-516b-4131-9313-e9b54575ef7c aborted


Subject: RE: Upgrading from core 5 to core 6.2
Author: Jay Stanley
Posted: 2018-07-06 16:08

Have you ran the Zenoss toolbox scans yet?


Subject: RE: Upgrading from core 5 to core 6.2
Author: Jane Curry
Posted: 2018-07-07 05:31

So it thinks that there is already a device with that IP address. Just worth a look under INFRASTRUCTURE -> Networks  and see if you can see the offending IP address.

Any chance that this is some sort of virtual address that may move from one device to another?

Most likely is that the original box is half-deleted so your best bet is Jay's suggestion to run the toolbox tools.


Jane Curry
Skills 1st United Kingdom

< Previous
Zenoss 6 Core missing ZenJMX Container
Core 6 Install files