TECHZEN Zenoss User Community ARCHIVE  

Activating a new delegate host

Subject: Activating a new delegate host
Author: [Not Specified]
Posted: 2017-02-10 10:57

I am trying to setting a resource (delegate) host with Zenoss 5. My master host has been setup for almost a year (upgraded to CC 1.2.1-1; Zenoss 5.2.1). I just built a delegate host using the instructions on (CC 1.2.2-1), including setting up all the SERVICED variables. I can add the delegate host into CC on my master host and the delegate is able to authenticate, but it's not listed as "active".

When I go to move a service over to the delegate host it doesn't work. The health check keeps failing. When viewing journalctl on the delegate there are no logs indicating a problem or the service even attempting to move to the delegate.

Any thoughts on what might be the cause

Subject: I rebuilt my delegate host
Author: [Not Specified]
Posted: 2017-02-13 16:18

I rebuilt my delegate host and tried adding it into control center and I still ran into the same problem.

I rebuilt my master host and added the delegate host to the fresh install and ran into the same problem.

The only log message I see that might pertain to this would be this sequence:

serviced[11336]: time="2017-02-13T22:09:27Z" level=info msg="Received new authentication token" expiration=1487027367 location="token.go:55" logger=auth
serviced[11336]: time="2017-02-13T22:09:32Z" level=info msg="Determined pool assignment for this delegate" hostid=853e7002 location="daemon.go:814" logger=cli.api master=":4979" poolid=default
serviced[11336]: time="2017-02-13T22:09:38Z" level=info msg="Updated master with delegate host information" hostid=853e7002 location="daemon.go:826" logger=cli.api master=":4979" poolid=default
serviced[11336]: W0213 22:10:27.935340 11336 connection.go:257] timed out waiting for connection

I'm also upload a picture of what I'm seeing in Control Center.

Anyway ill give it a go now, has this been fed back to Zenoss at all? I have noticed a few issues in various documentations over the last 6 months and they are quite receptive when you let them know something is wrong or missing.

Subject: RE: Trial and error based on
Author: Matt B
Posted: 2017-10-30 06:51

Hi, yes this worked fine thanks very much.

Matt B

< Previous
zenbatchload skips devices that don't support SNMP, any way around that?
Move data from 4.2.3 to 4.2.5