TECHZEN Zenoss User Community ARCHIVE  

Zenoss 4.2.5 auto deploy script problem?

Subject: Zenoss 4.2.5 auto deploy script problem?
Author: Pheripheral Pheripheral
Posted: 2016-11-09 08:08


I was wondering if anyone has recently had any problems using the autodeploy scripts for Zenoss 4.2.5.

I had a successful time with these autodeploy scripts towards the end of September, but yesterday (Oct 8th) I came to re deploy Zenoss 4.2.5 from then on a new machine and ran into a problem.

Specifically, during the run of the script I get a problem with some dependencies (edited highlights shown below..):

Ensuring Zenoss RPMs are not already present
Disabling SELinux...
Downloading zenoss_core-4.2.5-2108.el6.x86_64.rpm...
Using MySQL Community Release version 5.5.37-1
Installing EPEL Repo
Examining epel-rpm-macros-6-14.noarch
Marking to be installed
Resolving Dependencies
--> Running transaction check
---> Package epel-release.noarch 0:6-8 will be installed
---> Package epel-rpm-macros.noarch 0:6-14 will be installed
--> Processing Dependency: python-rpm-macros for package: epel-rpm-macros-6-14.noarch
--> Processing Dependency: python-srpm-macros for package: epel-rpm-macros-6-14.noarch
--> Processing Dependency: python2-rpm-macros for package: epel-rpm-macros-6-14.noarch
--> Finished Dependency Resolution
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Command failure: yum -y --nogpgcheck localinstall

I did a bit of digging and found that the epel-rpm-macros-6-14.noarch.rpm was updated at the start of October (see, so am wondering if this has upset things.

The changelog for that file seems to mention changing the python dependencies:

2016-10-03 - 6-14
- Drop py3 macro stubs now that we have python3 in EPEL6
2016-08-24 -  6-13
- Drop python macros; they're in the python-rpm-macros package now.
- Add dependency on the python-rpm-macros packages so that EPEL6 packages
need to manually add a dep on them.  (Python in RHEL6 can't be changed to
require them.)
- Move the two stub python3 definitions from the python macro file into the
main macro file.


Can anyone shed any light on this / any ideas of what to do to fix it


Subject: Examining the auto deploy
Author: Pheripheral Pheripheral
Posted: 2016-11-09 12:06

Examining the auto deploy script...

The Zenoss auto deploy script contains lines:


echo "Installing EPEL Repo"
wget -r -l1 --no-parent -A 'epel*.rpm' $epel_rpm_url
try yum -y --nogpgcheck localinstall */pub/epel/$elv/$arch/epel-*.rpm
disable_repo epel


gets various rpm packages from the fedoraproject site and then installs them.

The latest pair of changes to the epel-rpm-macros.rpm seem to suggest that the python-macros were dropped from this package as they were now in the python-rpm-macros package. A dependency to this package was also added to the epel-rpm-macros package.
however, as the zenoss install script only downloads packages called epel* , it does not pickup the python-rpm-macros package

Perhaps this needs adding into the zenoss auto deploy script

Subject: Fix?
Author: Pheripheral Pheripheral
Posted: 2016-11-17 05:32

I've been playing around with this and adding some further wget and yum lines around line 184 or so of the script to get and install the dependencies before installing the epel repo enables Zenoss to install ok...

echo "Installing EPEL Repo"

# get python macros dependencies and install
wget -r -l1 --no-parent -A 'python-rpm-macros*.rpm' $epel_rpm_url	
wget -r -l1 --no-parent -A 'python-srpm-macros*.rpm' $epel_rpm_url	
wget -r -l1 --no-parent -A 'python2-rpm-macros*.rpm' $epel_rpm_url	
try yum -y --nogpgcheck localinstall */pub/epel/$elv/$arch/python*rpm*.rpm

wget -r -l1 --no-parent -A 'epel*.rpm' $epel_rpm_url
try yum -y --nogpgcheck localinstall */pub/epel/$elv/$arch/epel-*.rpm
disable_repo epel

Subject: I have done some work with
Author: Jane Curry
Posted: 2016-12-09 06:28

I have done some work with this autodeploy script, following on from Pheripheral's good work above.

I found lots more breakages in the pre-req / co-req chains. I have put the package on GitHub at - it has a small README. Basically, you start with the install item on the wiki at and then replace from the Zenoss package with core-autodeploy.sh_update_20161208_zenup from my Git repository.

This version of the autodeploy script also installs zenup and the latest update (as of Dec 9th 2016) SUP - 671.

So far, I have only tested this on a VM with 1 CPU, 4GB RAM, running 64-bit CentOS 6.3.

If anyone else wants to test this (on a crash-and-burn system), I'd appreciate feedback.



Email:    Web:

Subject: Thanks!
Author: Pheripheral Pheripheral
Posted: 2016-12-12 06:35

Thanks very much for the script update.

I'm aiming to test this on a new Centos Build, but very unlikely this will be before the end of the year now.

Will report back once done (in January sometime probably)

Subject: After lots of playing (and
Author: [Not Specified]
Posted: 2016-12-13 05:40

After lots of playing (and failings) of auto-deploy scripts, I managed to find some *VERY* *VERY* simple instructions to get 4.2.5 up and running within 20 minutes without a single hitch.

I got fed up of trying different methods and complex instructions. Nearly threw in the towel and went Zabbix.

Yes, a couple of manual steps (downloading JRE), but I am sure someone can quickly automate this.

Taking no credit for the work, just the find!

Thanks, Neil.

Subject: Sorry you have had such a
Author: Jane Curry
Posted: 2016-12-13 12:03

Sorry you have had such a rough time with autodeploy scripts. I have been trying to update these. If you have tried with my scripts posted in the last few days - - and you have failed, I would appreciate feedback. The master branch is for CentOS; the ubuntu git branch is for Ubuntu.



Email:    Web:

Subject: @Jcurry
Author: [Not Specified]
Posted: 2017-01-06 08:38


Just pasing by and saw this.

During december, i installed using the script linked in the wiki.

I had to do some manual stuff to get it working:

yum erase rrdtool -y
rpm -Uvh perl-rrdtool-1.4.7-1.el6.rfx.x86_64.rpm rrdtool-1.4.7-1.el6.rfx.x86_64.rpm rrdtool-devel-1.4.7-1.el6.rfx.x86_64.rpm

alternatives --install /usr/bin/java java /usr/java/latest/bin/java 1
alternatives --config java

# edite coredeploy to remove the part that instals rrdtool

Subject: Thanks Rcocchiararo2 - as you
Author: Jane Curry
Posted: 2017-01-06 09:22

Thanks Rcocchiararo2 - as you point out, it rather depends on what you already have installed on your box. I started without either rrdtool or Java.

Ho hum - nothing is ever perfect *wink*



Email:    Web:

Subject: RE: Thanks Rcocchiararo2 - as you
Author: Odd Tore Oevretveit
Posted: 2018-01-30 17:50


Just tried the autoinstall script on a fresh CentOS 6.9 install

Almost worked, but some failures:

1. CentOS 6.9 comes with mysql already installed so first You need to yum remove mysql* then yum clean all
2. The java installation creates problems.
Not sure what the script does, but either CentOS comes with JDK installed, or the script installs JDK. So the start up of zenoss fails:

Configuring and Starting some Base Services and Zenoss...
Starting memcached: [ OK ]
Starting snmpd: [ OK ]
Zenoss not initialized. Performing first-boot initialization...
Fresh install pre steps
Please confirm that the JRE in the PATH is Oracle's version.
Command failure: /sbin/service zenoss start

So my solution was to continue with the instruction for manually installing Zenoss 4, from the install Java part.
Removing all versions of java and then downloading / installing the jre file mentioned in the manual install instruction worked.

Unfortunately, removing java also removes zenoss core.
So I also had to follow manual installation regarding 2.10 Install Zenoss Core after reinstalling java.

Hope this may help other users with issues.

Probably removing java as well as mysql before running the autoinstall script will work.
Not tested by me.

To remove java before running the autoinstall script use the command in the manual installation document:
yum -y remove $(rpm -qa | egrep -i '(jdk|jre|java)')

Odd Tore Oevretveit

Subject: RE: Thanks Rcocchiararo2 - as you
Author: Jane Curry
Posted: 2018-02-01 08:06

Thank you for your contributions to this project!

Jane Curry
Skills 1st United Kingdom

< Previous
Urgent Help required please
ZenOss and Cacti Issues