TECHZEN Zenoss User Community ARCHIVE  

Failed to create ZODB session database error

Subject: Failed to create ZODB session database error
Author: [Not Specified]
Posted: 2015-02-20 14:41

While attempting to start Zenoss 4.2.5 for the first time after installation on a CentOS 6.3 server, I receive the following "Access denied" error:

[root@Zenoss bin]# service zenoss start
Zenoss not initialized. Performing first-boot initialization...
Fresh install pre steps
Checking RRDtool version >= 1.4.7: [ OK ] 1.4.7
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
Dropping database: zodb_session
Failed to create ZODB session database

I tried issuing the following command as some threads in the Zenoss forums recommend, but it did not help:

UPDATE mysql.user SET Password = PASSWORD('password') WHERE User = 'root';

The install went flawelessly up to the point where I had to issue these commands:

mysqladmin -u root password ''
mysqladmin -u root -h localhost password ''

I get the following error:

[root@Zenoss zenoss]# mysqladmin -u root password ''
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: YES)'

I noticed at one point that a /root/.mysql_secret file was created with a default password:

[root@Zenoss ~]# cat .mysql_secret
# The random password set for the root user at Wed Feb 18 15:12:08 2015 (local time): lP4uIUpxhSsIJu1V

I tried removing the file, changing the root's password in the database to match the .mysql_secret file, nothing works.

Subject: use the auto-install script
Author: Andrew Kirch
Posted: 2015-02-26 12:00

use the auto-install script

Andrew Kirch

Need Zenoss support, consulting or custom development Look no further. Email or PM me!

Ready for Distributed Topology (collectors) for Zenoss 5 Coming May 1st from GoVanguard

< Previous
"Unable to create the initial Zenoss object database" error
Event and Clear the same event