TECHZEN Zenoss User Community ARCHIVE  

I'm trying to get the zenNrpeComponent to work

Subject: I'm trying to get the zenNrpeComponent to work
Author: [Not Specified]
Posted: 2014-06-04 11:35

I haven't been able to figure out the correct place to specify the remote command or where to specify the arglist

I'm a total zenoss newby trying to get the zenNrpeComponent to work
So Installed ConstructionKit 2.5, and zenNrpeComponent 2.1 on zenos 4.2.5

I've tested using nrpe_check and verified I can talk to the server.

The docs say - using standard GUI component management methods.
The component properties specify the remote command plugin to be called. The "arglist" is a newline-delimited list of arguments to be passed to the remote NRPE daemon (assuming it is configured properly to receive them).

But I haven't figured out how to do this Any help

Subject: Just edit the "Details" Pane
Author: [Not Specified]
Posted: 2014-06-05 13:28

Just edit the "Details" Pane (from the drop-down menu in the component grid) after selecting the component on the Device Status Page. The "arglist" property is editable from there.

Hope this helps,

Subject: I'm having the same issue
Author: Larry Ouellette
Posted: 2016-02-03 14:26

We have been using Zenoss for over a year now, but are having issues trying to use NRPE to to special tests on our Linux/Solaris servers via SNMP. We are not allowed to use ssh, so NRPE was suggested as an alternative. I have no prior experience with NRPE or Nagios.

I can execute a NRPE command from the command prompt on our Zenoss server :

/usr/lib64/nagios/plugins/check_nrpe -H and get a response, but there is zero documenation on how to use the Zenoss web interface to do the same thing.

After adding the Zenpacks there is a new entry in the + "Add Remote Nagios". When I select that it asks for a Plugin Command and Alias. What should go here I have also bound a local copy of the NRPE template to the device. I have tried adding a 'data source' to the local template, but I don't really know what to put in the Details pop-up. I have put everything from /usr/lib64/nagios/plugins/check_nrpe -H server-name to just /usr/lib64/nagios/plugins/check_nrpe No matter what I put in these fields, all I got were error events.

Is there any documnetation out there that can help set up some simple base-level NRPE checks If I can get that working, we will be converting a dozen or so shell scripts into NRPE scripts.

< Previous
$ZENHOME not set?
SOLVED - New instalation and Nan in all graph and DOWN ping