TECHZEN Zenoss User Community ARCHIVE  

Reportmail unable to load the address

Subject: Reportmail unable to load the address
Author: [Not Specified]
Posted: 2016-08-04 23:07

I tried to create a schedule report by using the reportmail command. here below is the command :

/opt/zenoss/bin/reportmail -u https://zenoss5/zport/dmd/reports#reporttree:.zport.dmd.Reports.Graph%20Reports.CPU%20Utilization -a -s "test of reportmail" -f xxx-p xxx

where -U is the zenoss manager user.

However, it showed the error as below :

Unable to load the address!
##### ERROR: phantomjs process return code: 1

Anyone got idea

Subject: Hi Wilsonlai,
Author: [Not Specified]
Posted: 2016-09-19 23:50

Hi Wilsonlai,

I am getting the same error. Did you solved it

Subject: seems like default.
Author: [Not Specified]
Posted: 2016-11-01 22:44

seems like default.

Subject: Sorry defect
Author: [Not Specified]
Posted: 2016-11-04 00:41

Sorry defect

Subject: This is definitely buggy. I
Author: Jane Curry
Posted: 2016-11-17 12:32

This is definitely buggy. I have tested the same equivalent reportmail command on 4.2.5 and 5.1.8. It works on 4.2.5; it fails on 5.1.8. The reportmail code has changed fairly significantly and there appear to be at least 2 problems with the new version.

The first problem is if you have a report that requires input and then to click some sort of "Generate" button to run the report. In 5.1.8 the input fields are usually python list items and the code expects them to be a simple string. You get an error message that sort-of points this out. I have a fix for this.

Once you get past that issue, you run into the "##### ERROR: phantomjs process return code: 1" problem. It appears that reportmail runs a command:

/opt zenoss/bin/phantomjs "/opt/zenoss/Products/ZenReports/rasterize.js", url, self.user, self.passwd, fullFileName

This fails in the "rasterize.js" which reports it is "Unable to load the address" though it does appear to have been passed the correct url. Don't have a fix for this yet.



Email:    Web:

Subject: OK. For a giggle I tried
Author: Jane Curry
Posted: 2016-11-30 12:13

OK. For a giggle I tried copying the from /opt/zenoss/Products/ZenReports on a Zenoss 4.2.5 SUP 671 system to the same place on a Zenoss 5.1.8 system. So far, it works.

To preserve such a change, you need to work around the container stuff of Zenoss 5 so:

serviced service shell -i -s reportmail425 zope bash where reportmail425 is the snapshot name

su - zenoss (once you are in the zope container)

.... copy the original for safety and replace with the one from Zenoss 4.2.5 .....

Test it - note that URLs WILL be different in a 5.x environment - I used:

reportmail -u "https://zenoss5.zen51/zport/dmd/Reports/Performance%20Reports/Availability%20ReportDeviceClass=%2F&System=%2F&DeviceGroup=%2F&Location=%2F&device=&severity=4&startDate=11%2F11%2F2016&endDate=11%2F18%2F2016&eventClass=%2FStatus%2FPing" -a -s "test of reportmail" -f -U jane -p

You then need to exit the zenoss shell, exit the zope container and commit the snapshot.



serviced snapshot commit reportmail425

Restart Zenoss entirely with:

serviced service restart Zenoss.core

Note that this will NOT be preserved if you upgrade your Zenoss 5!

There have been significant changes to between these 2 versions - there's no phantomjs or rasterize.js in the 4.2.5 version. Your mileage may vary but this did restore basic reportmail functionality for me.



Email:    Web:

Subject: I have uploaded the Zenoss 4
Author: Jane Curry
Posted: 2016-11-30 12:24

I have uploaded the Zenoss 4.2.5 SUP 671 to Gist at . Simply grab it, backup in /opt/zenoss/Products/Reports and copy this file to You will need to completely restart Zenoss.



Email:    Web:

Subject: Hi Jane,
Author: [Not Specified]
Posted: 2016-12-21 00:57

Hi Jane,

I have replaced the file but I found it cannot send the monthly, yearly report. On older version, we could add the "drange=3628800" at the end of the URL. However, this newer version can't. How to make it happen

< Previous
sql query to fetch the event archive between two time intervals in zenoss 4.2.5
ISO: tips to resolve Windows 10 Internet Explorer issue