TECHZEN Zenoss User Community ARCHIVE  

ZenHub not starting .. HELP!

Subject: ZenHub not starting .. HELP!
Author: [Not Specified]
Posted: 2015-10-22 09:34

I tried installing the layer2 Zenpack on Zenoss 5.0.7. I followed the Administration Guide for installing ZenPacks. On the wiki, it said it required the PythinCollector, i did not realize that Zenoss Core 5 already had it installed. When I tried to install both ZenPacks it came up with an error when trying to "Comitting container" = "F1022 09:05:33.215268 26993 shell.go:227] Error committing container: 8cfe442574f3d89a5e92bd3bc573fd83eb7f4b3a919a322e1d0c767351722adc (timeout)"

After that I had to restart the server, when it came back up Zenhub will not start. The health checks are showing alerts for rpc_listening and workers_running. When I list the available zenpacks, it shows ZenPacks.zenoss.Layer2 (broken). When I try to remove it I get the following errors:

ERROR:zen.ZenPackCmd:zenpack command failed
Traceback (most recent call last):
File "/opt/zenoss/Products/ZenUtils/", line 812, in
File "/opt/zenoss/Products/ZenUtils/", line 264, in run
self.options.removePackName, None)
File "/opt/zenoss/Products/ZenRelations/", line 204, in _getOb
return self._objects[id].__of__(self)
AttributeError: 'ZenPack' object has no attribute '__of__'
Command returned non-zero exit code 3. Container not commited.

I tried to restore my backup, but i get the following error: "Error 500: service zenpython found at bv28akyrqrcifa8yzf6itzszt"

Please help, i really don't want to start from scratch ( spent 2 weeks setting this up) :(


Subject: Also, I did make a snapshot,
Author: [Not Specified]
Posted: 2015-10-22 10:45

Also, I did make a snapshot, but it timed out. There's no snapshot listed. :(

Subject: just saw this. I'd recommend
Author: Andrew Kirch
Posted: 2015-10-22 22:29

just saw this. I'd recommend re-installing the zenpack, and see what you get. Make sure you follow closely and only have the indicated services started.

If that works you can then safely remove it.

Andrew Kirch

Need Zenoss support, consulting or custom development Look no further. Email or PM me!

Ready for Distributed Topology (collectors) for Zenoss 5 Coming May 1st from GoVanguard

< Previous
Installing Zenpacks in Centos 7
Error when status