TECHZEN Zenoss User Community ARCHIVE  

Installing Zenpacks in Centos 7

Subject: Installing Zenpacks in Centos 7
Author: [Not Specified]
Posted: 2015-10-29 13:09

Hi guys, I'm having some strange issues with my Zenoss setup and I could use an outside perspective.

I'm running Zenoss 5.0.7 on a Centos 7 (kernel v. 3.10.0-229.el7.x86_64) VM via an ESXI server. I followed the install guide PDF for Centos and didn't run into any major hiccups.

The application seems to run fine -- all of my devices show up and I can monitor them and all that fun stuff. However, my system architecture seems to be a little off.

Although my services show they run out of /opt/zenoss/bin, which ought to be the normal $ZENHOME, I have found that not only does $ZENHOME not exist, but /opt/zenoss does not exist. I have /opt/serviced, but no dedicated Zenoss install directory. As such, I cannot locate the file necessary to install ZenPacks.

Now, I was able to use

serviced service run zope zenpack create ZenPacks.ZenSystems.ApcPdu

to create a Zenpack and add it to the Zenoss UI, but it does not seem to actually install/activate the ZenPack. For example, I also added the Custom Network map ZenPack, but the new navigation tab does not show up, therefore I cannot access the plugin.

I did some experimenting with the Zenoss Virtual Appliance available on the wiki and there was a dedicated Zenoss install directory with $ZENHOME and all the expected files. I assumed I would have a similar environment if I built it from the ground up, but that doesn't seem to be the case.

Is my Zenoss install "normal" Am I missing something with regard to installing ZenPacks

Thanks for your help and please let me know any additional needed info.

Subject: Re: [Zenoss] Installing Zenpacks in Centos 7
Author: [Not Specified]
Posted: 2015-10-29 13:20

$ZENHOME being /opt/zenoss was the case for v4. v5 does everything in Docker containers. I think you'd need to figure out which container to connect to to run commands ... Have you tried installing from the Web interface James Pulver CLASSE Computer Group Cornell University

Subject: Thanks for the tip, I didn't
Author: [Not Specified]
Posted: 2015-10-29 13:22

Thanks for the tip, I didn't realize it had changed.

I haven't seen a way to install via the web interface, but I'd like to try it if it can be done. All of the Wiki I've read seems to indicate it can only be done on CLI. Plus I get this popup when I try:

"ZenPacks can no longer be added via the UI. Please use the CLI to add the zenpack. For example: > serviced service run zope zenpack create ZenPacks.awesome.Extension"

Any tips

Subject: Sorry I should have specified
Author: [Not Specified]
Posted: 2015-10-29 13:38

Sorry I should have specified, that's what I did and although they do get added to my Zenoss UI, they don't seem to be functioning correctly. Here's my ZenPack page, you can see the top 2 are ones I installed via CLI.

Subject: My limited experience with 5,
Author: Jane Curry
Posted: 2015-11-04 09:00

My limited experience with 5, as James says, is to follow the info in the Admin Guide in the ZenPacks chapter. If you simply want to install the .egg version of the ZenPack then use the install flag:
serviced service run zope zenpack install

If you have the source code and want to install in development mode then use the link parameter, rather than install.
Assuming you have the source code, starting at ZenPacks.ZenSystems.ApcPdu on your base Zenoss 5 system, change to the directory that holds ZenPacks.ZenSystems.ApcPdu and use:

serviced service run zope zenpack link install

Note that the holding directory seems to need to be world-writeable. The code directory hierarchy gets copied into the zope container under /var/zenoss/ZenPackSources and then gets installed in development mode within the Zope environment.

Please let me know how this works as I wrote the original ZenPack but no longer have access to devices to test against so have not tried using it in Zenoss 5.


Email:    Web:

< Previous
Change hostname/ip and/or restore backup in a new installation.
ZenHub not starting .. HELP!