TECHZEN Zenoss User Community ARCHIVE  

Change hostname/ip and/or restore backup in a new installation.

Subject: Change hostname/ip and/or restore backup in a new installation.
Author: [Not Specified]
Posted: 2015-10-30 12:42

Hi there

Going forward with my zenoss adventures, i was somehow able to fix my snapshot/backup issue.

After that, i tried upgrading from 5.0.4 to 5.0.7 (had issues there, but after resolving them, this was my first upgrade that actually reinstalled my extra zenpacks, except 2 develpment ones).

Now, i still need to change my hostname AND ip address, so i made a backup, and started over in the new machine with new ip/hostname, and restored there.

At first, i could not restore, cause it complained about a different hostid and SERVICED_REGISTRY being false.

it SEEMS that if i set that to 1 and create a "hostid" file in /etc/ with the old id, i can restore AND the "old" host is "found in the new one".

Without the hostid file, i can restore, but i get tons of messages saying that host is not found.

Now, since i had other issues, i decided to restore a VM snapshot, and try changing it's ip (only) or name + ip.

Now the host is once again NOT found.

i have a new ip, and either the old or the new name resolve to it (i tried both options).

Trying to discover my pool...
masterClient.GetHost 0b0add0c failed: hosts_server.go host not found (has this host been added)

How are we suposed to correctly change hostname/ip of the master host Is it logical that restoring a backup made in one server, requires the new one to think it has the same id
Any workarrounds

Subject: Have you figured this out yet
Author: [Not Specified]
Posted: 2015-11-02 08:05

Have you figured this out yet If not:

On the Hosts tab in Control Center, you need to add a host using your new IP. Then it should recognize your new host IP. Be sure to go to your Zenoss Core application and ensure that RabbitMQ, zenmail, zensyslog and zentrap are all pointing to the host with the new IP. I would restart all the services after that to ensure everything comes up smoothly.

Once you get the host added let me know. I've had network connectivity issues with changing IPs, so I'd like to see how this works for you.

Subject: As i recall, i made a backup,
Author: [Not Specified]
Posted: 2015-11-02 08:50

As i recall, i made a backup, removed the app from control center, removed the host, added a new one with the new ip, and restored the backup (with said caveats).

Previously i tried adding a new host (new name, same ip), but it would not let me.

I will now restore a snapshot of my vm to when i had the old host, and since i have a new ip and name, i will try what you suggest.

In any case, i still have random issues with zenoss snapshots failing (thus, no backups can be done, or upgrades unless i comment the snapshot step).
Also, as my other thread says, i have issues after upgrading from .4 to .7, so i might try a ONCE AGAIN, new clean install.

Subject: I was actually able to
Author: [Not Specified]
Posted: 2015-11-02 08:58

I was actually able to upgrade from .3 to .7, but then I had to change the IP afterwards, and that is when I have been having difficulties. It seems that once I change "hosts" in Control Center, (which I'm really just changing the IP of the VM), then Zenoss.Core can't ping anything, model hosts, etc.

A clean install with your new IP might be your best bet. I still have been running into the same IP change issue on a clean install of .7, but everything seemed to work fine before the IP change.

Subject: my issue is not network
Author: [Not Specified]
Posted: 2015-11-02 09:00

my issue is not network related tho.

After upgrading from .4 to .7 (first time EVER that zenpacks actually reinstall during the upgrade...), many (but far from all) server report exceeded threshods for memory and one for pagefile, but that info is BOGUS.

I have no idea why, and removing and re-adding them does not fix the thing.

Subject: The add host / delete old
Author: [Not Specified]
Posted: 2015-11-02 09:28

The add host / delete old host process went well.

My 5.0.4 instance works with that, and can ping/model stuff.

I am waiting tho, since the warnings of low disk space that should be there, have not appeared yet.

Still, i will need to test the clean install for 5.0.7, since upgrading still breaks it a little.

< Previous
ZenPack doesn't diplay some components in Zenoss 5
Installing Zenpacks in Centos 7