TECHZEN Zenoss User Community ARCHIVE  

UI customization using zenpacklib broken?

Subject: UI customization using zenpacklib broken?
Author: [Not Specified]
Posted: 2015-02-09 05:51

I created zenpacks using zenpacklib. All was well.
I moved to device UI customization and wanted to introduce new fields in the device overview panel of my device page.

I did some research and found out that
1. for= attribute on the configure.zcml is the key for adding Js scope
2. for="Products.ZenModel.Device.Device" make this global
3. for="..Ourdevice.ourdivice" limits the customization only to our device

Since we are using zenpacklib there is no explicit -> Class Ourdevice(Device).
This is part of the file of zenpack, which zenpacklib uses for configuration building.
But If I still continue to point the device (both label match and class match) to the configuration within
I get the following error while reinstalling zenpack.
ConfigurationExecutionError: : 'module' object has no attribute '__module__'
Now, can someone please help me overcome this

Also, I understand there is another zenpack helper (ZenPackGenerator) vs zenpacklib that I had used.
What is the difference here Why another library is being supported by zenoss instead of zenpacklib.

Thanks for your inputs.

Subject: Zenpacklib is much newer, and
Author: Andrew Kirch
Posted: 2015-02-09 22:48

Zenpacklib is much newer, and has more functionality for creating ZenPacks, but there's not much public documentation yet. Join us tomorrow for Dev Hours on IRC and you can get some interactive help!

Andrew Kirch

Need Zenoss support, consulting or custom development Look no further. Email or PM me!

Ready for Distributed Topology (collectors) for Zenoss 5 Coming May 1st from GoVanguard

Subject: Thanks Andrew. I am from
Author: [Not Specified]
Posted: 2015-02-09 23:58

Thanks Andrew. I am from India, and hopefully can connect to IRC at some reasonable time from my end.
Also, thanks for pointing that zenpacklib is newer. That definitely helped to save my effort in spending time with zenpackgenerator. I would appreciate some pointers on UI updates using zenpacklib if they are available any at all.

Much appreciated.

Subject: Issue sorted out
Author: [Not Specified]
Posted: 2015-02-12 01:11

Hi LN,
I tried on the configure.zcml on the root folder instead of the folder under browser with a single dot and it works now. Perhaps the ++resource++ is not absolute path but relative path pointing to the current directory Anyways the reported problem is sorted out. You can close the thread now as [Solved]

< Previous
Understand Zenoss New Structure
vSphere collector issue